Failed dependencies while installing libstdc++-devel-4.1.2-46.el5.i386.rpm

Advertisement
When i am trying to install the libstdc++-devel-4.1.2-46.el5.i386.rpm on Oracle Enterprise Linux server 5.4 (64BIT) OS, i am getting the following error:
# rpm -ivh libstdc++-devel-4.1.2-46.el5.i386.rpm
error: Failed dependencies:
libstdc++ = 4.1.2-46.el5 is needed by libstdc++-devel-4.1.2-46.el5.i386
Please note that the packages libstdc++-4.1.2-46.el5_4.1.x86_64 and libstdc++-4.1.2-46.el5_4.1.i386 are already in place. Following command shows the same.
#rpm -qa | grep libstdc++-
libstdc++-4.1.2-46.el5_4.1.x86_64
libstdc++-4.1.2-46.el5_4.1.i386
libstdc++-devel-4.1.2-46.el5_4.1.x86_64
compat-libstdc++-33-3.2.3-61.x86_64
compat-libstdc++-33-3.2.3-61.i386
compat-libstdc++-296-2.96-138.i386
Can some one suggest how to clear this dependency error ?
Edited by: user762181 on Dec 1, 2009 10:20 PM
Advertisement

Replay

JUST A GUESS work:
user762181 wrote:
When i am trying to install the libstdc++-devel-4.1.2-46.el5.i386.rpm on Oracle Enterprise Linux server 5.4 (64BIT) OS, i am getting the following error:
# rpm -ivh libstdc++-devel-4.1.2-46.el5.i386.rpmits i386 pack.
error: Failed dependencies:
libstdc++ = 4.1.2-46.el5 is needed by libstdc++-devel-4.1.2-46.el5.i386
Please note that the packages libstdc++-4.1.2-46.el5_4.1.x86_64 and libstdc++-4.1.2-46.el5_4.1.i386 are already in place. Following command shows the same.
#rpm -qa | grep libstdc++-
libstdc++-4.1.2-46.el5_4.1.x86_64
libstdc++-4.1.2-46.el5_4.1.i386
libstdc++-devel-4.1.2-46.el5_4.1.x86_64
compat-libstdc++-33-3.2.3-61.x86_64
compat-libstdc++-33-3.2.3-61.i386
compat-libstdc++-296-2.96-138.i386
Can some one suggest how to clear this dependency error ?cant you find any x86_64 packs??
cant you have apt package-manager??if you have try it through that.
>
Edited by: user762181 on Dec 1, 2009 10:20 PMEdited by: mango_boy on Dec 4, 2009 6:42 AM