Conatinually asks to update plug-ins that are already updated?

Advertisement
When I check my plugins, a few of them say to update due to vulnerability issues. Either some have been updated already and still ask to be updated or when they are actually updated and everything is refreshed, the plugins still show that they need to be updated.
Advertisement

Replay

You don't need to do anything since Java 7 Update 51 is not vulnerable (afaik) and is the recommended version offered at http://www.java.com/en/download/manual.jsp and http://www.java.com/en/download/
If you check the "[http://www.java.com/en/download/installed.jsp?detect=jre&try=1 Do I have Java?]" link at http://www.java.com/en/download/ and run the Java Detection applet it will tell you that you have the recommended Java installed (Version 7 Update 51).
Related bugs:
*[https://bugzilla.mozilla.org/show_bug.cgi?id=985968 Bug 985968] - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed.
*[https://bugzilla.mozilla.org/show_bug.cgi?id=985056 Bug 985056] - Java JDK 8 released
P.S. The bug reports are for information only. Don't comment in bug reports unless you have something constructive to add (see [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette]).