Cant lookup a TopicConnectionFactory using RefFSContextFactory

Advertisement
I am using MQ 5.3 and Websphere 4.0.
I can successfully use JMSAdmin to load my objects into a local file. I have a TopicConnectionFactory called myTCF, and a Topic called Java.
Here is my JMSAdmin.config entries:
INITIAL_CONTEXT_FACTORY=com.sun.jndi.fscontext.RefFSContextFactory
PROVIDER_URL=file:/C:/tmp
Here is my setup file for JMSAdmin:
def ctx(mq)
chg ctx(mq)
def tcf(MyTCF) qmgr(QM1)
def t(Java) topic(computers/Java)
display ctx
end
This creates a .bindings file int the c:\tmp\mq directory. Here is a piece of the file:
#This file is used by the JNDI FSContext.
#Fri Oct 24 10:30:44 EDT 2003
Java/RefAddr/10/Encoding=String
Java/RefAddr/9/Encoding=String
MyTCF/RefAddr/23/Encoding=String
MyTCF/RefAddr/12/Content=5000
MyTCF/RefAddr/23/Content=1
MyTCF/RefAddr/10/Type=MBS
MyTCF/RefAddr/7/Type=SPAG
MyTCF/RefAddr/10/Content=10
MyTCF/RefAddr/10/Encoding=String
Java/FactoryName=com.ibm.mq.jms.MQTopicFactory
MyTCF/RefAddr/21/Content=60000
MyTCF/RefAddr/21/Type=SRI
MyTCF/RefAddr/12/Encoding=String
MyTCF/RefAddr/1/Type=TRAN
Java/RefAddr/5/Type=TC
My code to reference these objects can read the initial context (mq), but I cant seem to lookup these objects. I use the same InitalContextFactory and ProviderURL, but my ctx.lookup() keeps failing with javax.naming.NameNotFoundException.
I tried mq/myTCF, mq.myTCF, myTCF, jms/mq/myTCF, ect.
Am I using the right syntax for this TopicConnectionFactory?
Any help would be greatly appreciated.
Thanks.
Carl
Advertisement

Replay

I found my own problem.
The provider URL needed to have "/mq" added:
ProviderURL = file:/C:/tmp/mq
This is odd, since my JMSAdmin provider URL, only had the /tmp.....
The lookup() variables should be:
Hopefully this will be a good example for someone else....
MyTCF
Java

CS6. I cant duplicate lighting effects using an alt key, just like in CS3. I dont want a new light i want to duplicata an existing one that i created.

CS6. I cant duplicate lighting effects using an alt key, just like in CS3. I dont want a new light i want to duplicata an existing one that i created. Nie mogę duplikować zaprogramowanego efektu świetlnego za pomocą altu tak jak w poprzednich wersjac

Why i cant send itunes gift using my credit card?

Why i cant send itunes gift using my credit card?What happens when you try to send a gift ? If you are getting an error message then what does it say ? If you are getting a message to contact iTunes Support when trying to send it then to do so (these

TS3682 i cant restore my iphone using itunes

i cant restore my iphone using itunesSee Here  >  http://support.apple.com/kb/HT1808 You may need to try this More than Once... Be sure to Follow ALL the Steps... But... if the Device has been Modified... this will Not necessarily work.Read other 2 a

Cant Hear inless I use speaker phone

I have the old model 4g and it just started today, I cant hear inless I use speaker phone, Ringtone works but music will not play. Also when I put my ear to phone the backround does not disappear.    Thanks for trying those steps already, sbond0128. 

Cant stream movies while using airplay

CAnt stream movies while using airplay. says error occuredWelcome to the Apple Community. Try the following steps, check whether things are working after each step where appropriate, before trying the next. Check AirPlay is turned on on the Apple TV

Datasource Lookup from WSAD using POJO - CastException looking up DB2 Data

I try to look up datasource from WSAD test server using stand alone POJO. Code is like: Hashtable properties = new Hashtable(); properties.put(Context.INITIAL_CONTEXT_FACTORY, "com.ibm.websphere.naming.WsnInitialContextFactory"); properties.put(

Security questions through iPad expired time every 1 sec and i cant put them to use AppStore

I put a security questions already in my account , but when I try to use AppStore in my iPad It ask me to put moré security questions , the problem is when i try to do It every time It says the time has expired . That i should start again . I tryied

How to write the jndi lookup for ejb using oc4j server in jdeveloper

Hi All, i am new to the JDeveloper. i want to develop the session bean in JDeveloper using the OC4J server. how to write the jndi lookup in cllient. what are the xml files need to deploy the application. where can i mention the JNDI name in xml file.

Problem with ERP User Role: Cant do Bank Reconciliation using SM35 Pls help

Hi Everyone, I'm having soem problems. A user can upload the electronic bank statement (MT940 format) using FF_5 however when they attempt to process it using SM35 the file is not there. I think we might be missing an authorisation object or somethin

Lookup fais when using two appservers ..... weblogic bug??

Hi I'm using following code to access two different resources on 2 weblogic servers. (both servers are weblogic 6.1 sp 1) // this is to access data source in appserver 1 Hashtable htblProps1 = System.getProperties(); InitialContext ic = new InitialCo

Cant uninstall, instal or use itunes..

I get an error message when I try to uninstall, find itunes.msi, cant use it because it is a different age... when I do find it.... what do I dooHi youngbloodmary, Have you been using the steps in the following article to help you uninstall iTunes? R

Lookup in Xi using XSLT with Java enhancement "Error"

Hi Experts, I need your advice urgently. I have done message mapping using XSLT mapping with Java enhancement. I included the code for SAP DB connection to read from the table. I imported both the sapdbc-7_6_00_30_5567 Driver.jar and my custom jar in

Issues when we try to lookup for EJB using T3 protocol

Hi, We have EJB's deployed in Weblogic server and we are trying to invoke them using T3 protocol. We are facing problem as its giving the following exception javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3://170.0

Why I cant download an apps using my apple id?

I dont know why i cant login my apple id account in my ipod touch. Can you guys help me? The password and user id is correct (just to let you know)Create a NEW account/ID for her using these instructions. Make sure you follow the instructions. Many d

Cant call mobile phones using Skype in Serbia

Dear ladies and gentlemen, My parents are currently in Serbia and they are using Skype. They have 30€ of credit on their Skype account and use it to call numbers outside of Serbia. Now, this works without problems for landlines (e.g. in Germany) but

Cant see all devices using airport utility

why is it that when using windows xp and wired ethernet i can not see all apple devices using airport utility? If i switch to wireless i can see all of the devices just fine.To view Ethernet devices you need to use AirPort Utility 5.6. This can be in

Smartform new version - i cant see the styles used from Smartstyles

Hello all I got a new computer with new SAP GUI. I just found out that the text editor displaying a text element does not show the character (or paragraph) style defined in related Smartstyle object. anybody could help where to change related view se

Cant get online when using password

hello i have a question about connecting with airport. for some reason i cant seem to connect at my friends house (where i do most of my work). He gave me the correct password and i can see the port so i know im not out of range. the strange thing is

I pod disabled  and cant remember passcode. cannot use itunes as it wants update and restore  need to use passcode and the hold sleep/wake key and home key doesnt put it in DFU either . any help ?

My ipod has been disabled as I cant remember the passcode . When doing a restore on I Tunes it will only update and restore , the update doesnt work as the phone is locked and I need a passcode. I have tried the other way which is to hold the sleep/w